2,726

Hi Sarami

Trying to dump this disc for CD-i
https://cdn.discordapp.com/attachments/755249778455216138/777022831791833088/IMG_20201114_041041.jpg

I am seeing some weird stuff in the logs that says the MSF is CDTV Specific:
can you take a look at the logs please?

Jigsaw.rar
    191.42 MB     https://1fichier.com/?t1n3qchq1h7nyx4b7ki6

2,727

wiggy2k wrote:

the MSF is CDTV Specific:

https://github.com/saramibreak/DiscImag … r/issues/8

Adr 6 is an undocumented flag. I don't know what this flag means. I thought this flag only exists in amiga CD, but CD-i also has it. I'll change the "CDTV Specific" to others.

2,728

This error seems common on CDi. Happens with the game Jigsaw for both wiggy and me. It's a cheap game if you need a copy for tests.

2,729

sarami wrote:
wiggy2k wrote:

the MSF is CDTV Specific:

https://github.com/saramibreak/DiscImag … r/issues/8

Adr 6 is an undocumented flag. I don't know what this flag means. I thought this flag only exists in amiga CD, but CD-i also has it. I'll change the "CDTV Specific" to others.

http://www.mediafire.com/file/eq80y20l9 … st.7z/file
I don't test yet.

2,730 (edited by user7 2020-11-17 06:44:56)

I bought two copies of Jigsaw, both have that weird Main Error thing, but they both match each other

https://drive.google.com/file/d/1cOAErb … sp=sharing

---

Also can you have a look at this and let me know if it's okay? It's a rare CD-i disc on borrow: https://drive.google.com/file/d/11S61m2 … sp=sharing

2,731

user7 wrote:

if it's okay?

I think both discs are no problem as mastering error sectors. Hereafter, admin or moderator judge it.

2,732

Thanks, also can you have a look at this? https://drive.google.com/file/d/1lbh0vA … sp=sharing

>Write Offset: 88200

O_O

2,733

user7 wrote:

>Write Offset: 88200

Surprisingly, it's correct.

========== OpCode[0xd8]: SubCode[0]: Check Drive + CD offset ==========
========== LBA[000000, 0000000]: Main Channel ==========
       +0 +1 +2 +3 +4 +5 +6 +7  +8 +9 +A +B +C +D +E +F
0000 : 3D E5 D1 8B 1C 67 49 EA  B6 CF 36 D4 16 DF 4E D8   =....gI...6...N.
0010 : 34 5A 97 7B 2E A3 5C 79  F9 E2 C2 C9 91 96 EC 6E   4Z.{..\y.......n
0020 : CD EC 55 8D FF 25 80 1B  20 0B 58 07 7A 82 A3 21   ..U..%.. .X.z..!
0030 : B9 D8 72 DA A5 9B 3B 2B  53 5F 7D F8 21 82 98 61   ..r...;+S_}.!..a
0040 : AA A8 7F 3E A0 10 78 0C  22 85 D9 A3 1A F9 CB 02   ...>..x.".......
0050 : D7 41 9E B0 68 74 2E A7  5C 7A B9 E3 32 C9 D5 96   .A..ht..\z..2...
0060 : DF 2E D8 1C 5A 89 FB 26  C3 5A D1 FB 1C 43 49 F1   ....Z..&.Z...CI.
0070 : F6 C4 46 D3 4D CE 55 27  00 FF FF FF FF FF FF FF   ..F.M.U'........
0080 : FF FF FF 00 01 80 00 62  00 28 20 1E 80 08 40 06   .......b.( ...@.
0090 : 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00   ................
00A0 : 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00   ................

When msf is descrambled, it's "00 00 00", not "00 02 00"

2,734 (edited by reentrant 2020-11-24 22:43:06)

FYI: I have tested a combined plus offset disc with mastering error on Asus BW-16D1HT and the result is the same as on Plextor 760. Probably more tests are needed but it seems like this Asus drive is finally a good replacement drive for all these retro Plextor drives...

EDIT:

Sarami I have such disc:

     Combined Offset(Byte)     24, (Samples)     6
    -   Drive Offset(Byte)     24, (Samples)     6
    ----------------------------------------------
           CD Offset(Byte)      0, (Samples)     0

ASUS gave me wrong image. Last 6 samples of image are all zeroes. They should contain some data. Can you fix this?

EDIT2:

Reripped the disc and it was ok next time. I noticed that when there's more than one lead-out sector in cache it's ok. Maybe the computations are off by one somewhere?

2,735

reentrant wrote:

ASUS gave me wrong image. Last 6 samples of image are all zeroes.

I also tried it with the same combined offset disc using the latest test version (20201115T172518) and it was no problem...

wiggy2k wrote:

I am seeing some weird stuff in the logs that says the MSF is CDTV Specific:

Was this solved?

2,736

sarami wrote:

I also tried it with the same combined offset disc using the latest test version (20201115T172518) and it was no problem...

Another one. Offset +1617 and 3 or 4 lead-out sectors - last 3 sectors were off by one (MSF).

I think something bad happens when there's not enough lead-out (aa) sectors in the cache. Maybe retry cache read by reading more sectors? I have dumped maybe 20 plus offset discs and had these 2 cases. Both had very few 'lead-out' sectors printed to console. This looks like a problem with drive cache...

2,737

http://forum.redump.org/post/85629/#p85629 - Jaguar support is broken? Track 6 is empty, while it should have some data (2019 DIC dumps it correctly).