2,751

sarami wrote:
Madroms wrote:

I have a problem with a multisession disc.
It is very slow beginning at sector 61105 then hangs the ODD after a while. I need to switch it off electrically then on to have access to it again.

It's a known issue. https://github.com/saramibreak/DiscImag … /issues/41
Use DVD model (PX-7xx).

Great, it works with 716A. Thanks.
I didn't see the issues on GH.

Adding a warning or a stop (like when using ODD without latest firmware) when someone try to dump a multisession disc with PW4012 and other ODD not compatible: is it possible?

I pretty sure you will have some other users asking the same in the future wink

Saturn Database {-} Retro Deals search engine that helps you find stuff (plextor drives, games, etc.) easily on eBay {-} My Redump Logs

Lame wrote:

Hello. I have problem with newest version of DICUI (1.8). Today i tried to dump Midtown Madness which turned out it's verification, but 1.8 version made 3 different result and 1.7.1 two times in row matched to dump on main site. I spotted 2 times this problem occured also with other disc I tried:

Creating .scm (LBA)  37068/301245[F:ProcessReadCD][L:288] GetLastError: 1117, Nie mo┐na wykonaŠ ┐╣dania z powodu b│ŕdu urz╣dzenia We/Wy.

(Cannot execute task, because of input output device error)

I have Plextor PX-755SA

I have similar errors. I think they are related to bad cabling and controller is dropping the device from time to time.

2,753 (edited by zcal 2020-12-11 18:33:03)

I'm trying to dump the HD area of my Dreamcast discs.  I have a TS-H192C drive, which is either recommended or untested but should work.  sarami confirmed its ability to dump the HD area a few years ago.

I get the following errors when I try to dump from any of my Dreamcast discs.  I'm using DIC version 20201101.

StartTime: 2020-12-11T11:17:20-0600
Set the drive speed: 1411KB/sec
[WARNING] /c2 isn't set. The result of dumping may be incorrect if c2 error exists.
This drive can read data sectors at scrambled state [OpCode: 0xbe, C2flag: 0, SubCode: 0]
This drive can read data sectors at scrambled state [OpCode: 0xbe, C2flag: 0, SubCode: 1]
This drive can read data sectors at scrambled state [OpCode: 0xbe, C2flag: 0, SubCode: 2]
LBA[045000, 0x0afc8]: [F:ExecSearchingOffset][L:185]
        Opcode: 0xbe
        ScsiStatus: 0x02 = CHECK_CONDITION
        SenseData Key-Asc-Ascq: 05-24-00 = ILLEGAL_REQUEST - INVALID FIELD IN CDB
lpCmd: be, 04, 00, 00, af, c8, 00, 00, 01, f8, 04, 00
dwBufSize: 2448
Couldn't read data sectors at scrambled state [OpCode: 0xbe, C2flag: 0, SubCode: 4]
LBA[045000, 0x0afc8]: [F:ReadCDForCheckingSubQAdr][L:949]
        Opcode: 0xbe
        ScsiStatus: 0x02 = CHECK_CONDITION
        SenseData Key-Asc-Ascq: 05-24-00 = ILLEGAL_REQUEST - INVALID FIELD IN CDB
lpCmd: be, 04, 00, 00, af, c8, 00, 00, 02, f8, 04, 00
dwBufSize: 2448
Checking SubQ adr (Track)  3/ 3
LBA[045100, 0x0b02c]: [F:ReadCDForCheckingSubRtoW][L:1091]
        Opcode: 0xbe
        ScsiStatus: 0x02 = CHECK_CONDITION
        SenseData Key-Asc-Ascq: 05-24-00 = ILLEGAL_REQUEST - INVALID FIELD IN CDB
lpCmd: be, 04, 00, 00, b0, 2c, 00, 00, 01, f8, 04, 00
dwBufSize: 2448

Reading DirectoryRecord   14/  14
Set OpCode: 0xbe, SubCode: 4(Pack)
LBA[044999, 0x0afc7]: [F:ProcessReadCD][L:288]
        Opcode: 0xbe
        ScsiStatus: 0x02 = CHECK_CONDITION
        SenseData Key-Asc-Ascq: 05-24-00 = ILLEGAL_REQUEST - INVALID FIELD IN CDB
EndTime: 2020-12-11T11:17:39-0600

2,754

I have a problem with latest DIC test vs. DIC 20200921 for a multisession disc, on track 3 (data track, 2nd session).
Logs, picture of 1st sector of data track and onscreen reports of DIC test attached.

Dump with latest test version seems wrong.

Post's attachments

DICtest20201127___on screen.txt 3.02 kb, 2 downloads since 2020-12-12 

KITTY DIC20200921-logs.rar 1.45 mb, 1 downloads since 2020-12-12 

KITTY DICtest20201127-logs.rar 1.47 mb, 1 downloads since 2020-12-12 

KITTY Track 3.PNG 122.19 kb, 1 downloads since 2020-12-12 

You don't have the permssions to download the attachments of this post.
Saturn Database {-} Retro Deals search engine that helps you find stuff (plextor drives, games, etc.) easily on eBay {-} My Redump Logs

2,755

Madroms wrote:

I have a problem with latest DIC test

Deleted unused code. (Not test)
https://www.mediafire.com/file/eq80y20l … st.7z/file

zcal wrote:

I'm trying to dump the HD area of my Dreamcast discs.  I have a TS-H192C drive

Sorry, I don't have it anymore, so I can't test it.

2,756

sarami wrote:
Madroms wrote:

I have a problem with latest DIC test

Deleted unused code. (Not test)
https://www.mediafire.com/file/eq80y20l … st.7z/file

Thanks. Logs attached.
It seems ok now. Let me know if you find something weird with these latest logs.

Post's attachments

Hiza_no_Ue_no_Partner_Kitty_on_Your_Lap_Appendix_CD_Extra_GOOD-logs1.rar 1.46 mb, 2 downloads since 2020-12-13 

You don't have the permssions to download the attachments of this post.
Saturn Database {-} Retro Deals search engine that helps you find stuff (plextor drives, games, etc.) easily on eBay {-} My Redump Logs

2,757

I got a CDi prototype CD-r. Dumped it with 760SA and 716A. Same hashes, but has Main Error. I'm guessing these are mastering related?

I got the same hash all three times I dumped it https://drive.google.com/file/d/1rRANLF … sp=sharing

All my posts and submission data are released into Public Domain / CC0.

2,758

user7 wrote:

I got a CDi prototype CD-r. Dumped it with 760SA and 716A. Same hashes, but has Main Error. I'm guessing these are mastering related?

I got the same hash all three times I dumped it https://drive.google.com/file/d/1rRANLF … sp=sharing

It's weird.
There is "01 80 00 62" in LBA 0, but "01 82 00 62" in LBA 1.
From LBA -1 to LBA -150 is also "01 80 00 62" according to _disc.txt

========== Check Pregap sync, msf, mode ==========
      1 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 80 00 62
      2 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 80 00 62
      3 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 80 00 62
      4 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 80 00 62
      5 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 80 00 62
        :
    149 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 80 00 62
    150 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 80 00 62
    151 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 82 00 62
    152 : 00 FF FF FF FF FF FF FF FF FF FF 00 01 82 01 62

Hey Sarami, got any feedback on this:

http://forum.redump.org/topic/33374/iss … peg-dumps/

I don't get notifications from this forum, and i don't often check PMs here as a result. If you need to reach me, please just email me or contact F1ReB4LL.

2,760 (edited by fuzzball 2020-12-30 13:40:11)

Is this error caused by a scratched disc?
I dumped it three times, all with the same result.

logs: https://www.dropbox.com/s/fji0tajumxrm7f2
db: http://redump.org/disc/38495/

*EDIT*
The dump by IsoBuster had no errors and the hashes matched.

*EDIT2*
The test version (20201223) had the same result.
https://www.dropbox.com/s/sm2is6ve9ex2d1r

2,761

fuzzball wrote:

Is this error caused by a scratched disc?

Same. http://forum.redump.org/post/85823/#p85823

2,762

Something wrong with the gap detection again.

LBA[008100, 0x01fa4]: Track[04]: P-channel pregap size (00:02:00) vs Q-channel pregap size (00:01:74) mismatch [1 sector(s)]
LBA[012300, 0x0300c]: Track[07]: P-channel pregap size (00:02:00) vs Q-channel pregap size (00:01:74) mismatch [1 sector(s)]
LBA[021600, 0x05460]: Track[11]: P-channel pregap size (00:02:00) vs Q-channel pregap size (00:01:74) mismatch [1 sector(s)]

Mismatch is due to EAN sectors, why weren't the gaps fixed?

Post's attachments

WINNING_Post.7z 497.52 kb, 2 downloads since 2021-01-01 

You don't have the permssions to download the attachments of this post.

2,763

Updated. https://www.mediafire.com/file/eq80y20l … st.7z/file

2,764

Worked fine now, thanks.

Post's attachments

WINNING_Post_2.7z 487.17 kb, 1 downloads since 2021-01-01 

You don't have the permssions to download the attachments of this post.

2,765

*2021-01-02
- added: support the multi-track CD-i (1st track is data, others audio)
- added: show the error message when multi-session disc is dumped by the plextor cdrom drive
- added: show the error message (Multi sector reading isn't supported now even if 0xf1 is supported)
- fixed: subQ when there is MCN or ISRC in the 1st pregap sector or last sector of the track
- fixed: failed to dump the multi-session disc from 20200604
- fixed: buf size to store the fullpath
- improved: subQ Adr 6

2,766

sarami wrote:

- added: show the error message (Multi sector reading isn't supported now even if 0xf1 is supported)

... added /mr for testing purpose (it can read multi sector)

2,767

Hello,

I have a question, i bought a asus bw-16d1h, if i flash it with MK 3.10, and i want do dump a Cd-i game DIC
doesnt sees a disc in the drive,

 LBA[000000, 0000000]: [F:TestUnitReady][L:44]
    Opcode: 00
    ScsiStatus: 0x02 = CHECK_CONDITION
    SenseData Key-Asc-Ascq: 02-3a-01 = NOT_READY - MEDIUM NOT PRESENT - TRAY CLOSED  


if i flash it with DE 3.02 firmware it does show, but gives me some errors


Checking reading lead-out -> This drive can't read the lead-out
But 0xF1 is supported

LBA[195492, 0x2fba4]: [F:ReadCDForCheckingReadInOut][L:801]
    Opcode: 0xbe
    ScsiStatus: 0x02 = CHECK_CONDITION
    SenseData Key-Asc-Ascq: 05-21-00 = ILLEGAL_REQUEST - LOGICAL BLOCK ADDRESS OUT OF RANGE
lpCmd: be, 04, 00, 02, fb, a4, 00, 00, 01, f8, 00, 00
dwBufSize: 2352

LBA[000000, 0000000]: [F:ReadCDForSegaDisc][L:2047]
    Opcode: 0xa8
    ScsiStatus: 0x02 = CHECK_CONDITION
    SenseData Key-Asc-Ascq: 05-64-00 = ILLEGAL_REQUEST - ILLEGAL MODE FOR THIS TRACK
lpCmd: a8, 00, 00, 00, 00, 00, 00, 00, 00, 01, 00, 00
dwBufSize: 2048

LBA[000018, 0x00012]: [F:ReadVolumeDescriptor][L:531]
    Opcode: 0xa8
    ScsiStatus: 0x02 = CHECK_CONDITION
    SenseData Key-Asc-Ascq: 05-64-00 = ILLEGAL_REQUEST - ILLEGAL MODE FOR THIS TRACK
lpCmd: a8, 00, 00, 00, 00, 12, 00, 00, 00, 01, 00, 00
dwBufSize: 2048
LBA[195490, 0x2fba2]: Track[01]: This sector is data, but sync is invalid
========== LBA[195490, 0x2fba2]: Main Channel ==========
       +0 +1 +2 +3 +4 +5 +6 +7  +8 +9 +A +B +C +D +E +F
0000 : 20 20 20 20 20 20 20 20  20 20 20 20 20 20 20 20                   
LBA[195491, 0x2fba3]: Track[01]: This sector is data, but sync is invalid
========== LBA[195491, 0x2fba3]: Main Channel ==========
       +0 +1 +2 +3 +4 +5 +6 +7  +8 +9 +A +B +C +D +E +F
0000 : 20 20 20 20 20 20 20 20  20 20 20 20 20 20 20 20                   
LBA[195490, 0x2fba2]: Track[01]: Invalid sync. Skip descrambling

Is the MK 3.10 firmware not supported ?
On clonecd it dumps without any errors,

2,768 (edited by user7 2021-01-07 05:08:01)

150 errors, "No unintentional C2 errors" this is all good

dumped on two drives:
https://drive.google.com/file/d/1toZJtW … sp=sharing
https://drive.google.com/file/d/10MXBIz … sp=sharing

All my posts and submission data are released into Public Domain / CC0.

2,769

user7 wrote:

150 errors, "No unintentional C2 errors" this is all good

It seems it's "audio silence".

Nextria wrote:

Is the MK 3.10 firmware not supported ?

Yes.

2,770

This dump is good? appears to be Safe Disc

https://cdn.discordapp.com/attachments/ … tled-1.jpg

logs: https://drive.google.com/file/d/1nvKUfw … sp=sharing

All my posts and submission data are released into Public Domain / CC0.

Sarami, I was told to post some logs here for you to take a look at.

I have some Karaoke CD-i discs that seem a bit weird. When I select CD-i as system in DICUI, the dump itself seems to go right but an error pops up that EdcEcc.txt and the .scm file are missing (which are indeed missing). When I dump as Audio CD it works fine.

I don't know what kind of disc this is though. DIC detects 15 audio tracks and no data-tracks. However, the manual of the disc shows some kind of track selection screen. And even if it were a pure audio-disc and it would be just some kind of built-in CD-i music player, it still doesn't make sense because the manual shows that there's track information and even some kind of images. I'm not 100% sure whether the images come from the disc though, or whether they are built-in images.

Furthermore, when looking at the disc in IsoBuster, IsoBuster shows 16 tracks total (whereas DIC detects 15). However, track 0 has a red plus icon in front of it which means according to the manual:

This icon can be placed next to a track a session or a file icon.
It means that IsoBuster felt the need to compensate or alter what the drive returned to get to the data.
E.g. CD-i discs are often not correctly recognized by CD/DVD-ROM drives and IsoBuster tries to compensate for that (possibly assumes tracks at certain locations) to be able to give access to the data.

Plus, in IsoBuster track is much larger than the other tracks. Track 0 is about 180MB and the other ones are around 30-40 MB. In DIC however, track 1 (the first track) is about 220 MB; seems to be the data that IsoBuster shows as Track 0 and Track 1 combined.

I'm a noob when it comes to all these disc technicalities though, so the above might be total crap.

Logs of the dump with CD-i as selected system are here: http://a.tmp.ninja/isB7QKpDiEc1.7z

2,772 (edited by sarami 2021-01-09 10:10:08)

user7 wrote:

This dump is good?

Yes.

Landcross wrote:

I don't know what kind of disc this is though.

It's CD-i ready disc. See below.
http://redump.org/disc/36178/
http://redump.org/disc/35804/
http://redump.org/disc/74944/

Landcross wrote:

in IsoBuster track is much larger than the other tracks. Track 0 is about 180MB and the other ones are around 30-40 MB. In DIC however, track 1 (the first track) is about 220 MB; seems to be the data that IsoBuster shows as Track 0 and Track 1 combined.

Track 0 IsoBuster says is the pregap sector of Track 1. DIC doesn't divide it.

2,773

I'm having a trouble dumping Action Replay Version 2.34 (PlayStation 2 CD) in my Plextor PX-755A.
Right on dump start I get

LBA[323849, 0x4f109]: [F:ReadCDForCheckingReadInOut][L:701]
    Opcode: 0xd8
    ScsiStatus: 0x02 = CHECK_CONDITION
    SenseData Key-Asc-Ascq: 03-02-8d = MEDIUM_ERROR - VENDOR UNIQUE ERROR
lpCmd: d8, 00, 00, 04, f1, 09, 00, 00, 00, 01, 00, 00
dwBufSize: 2352

I can start the dump just fine using my other ASUS BW-16D1HT drive but it has some reading issues with some GameShark / ActionReplay discs, very slow reading and takes forever - don't think it's related though.
Using the latest DIC.

2,774

Mix mode disc, sub errors are mastering errors?

Thanks smile

https://drive.google.com/file/d/14Ut2vT … sp=sharing

All my posts and submission data are released into Public Domain / CC0.

2,775 (edited by sarami 2021-01-11 03:27:26)

user7 wrote:

Mix mode disc, sub errors are mastering errors?

What sub errors?

superg wrote:

I'm having a trouble dumping

Disc or drive problem? I don't know.

----
Uploaded test version.
- added: 0xF1 drive (ASUS BW-16D1HT 3.00, HL-DT-ST BH14NS40 1.00 N1A11A1, BH14NS58 1.00,
                     BH16NS40 1.00 N1A29A2, 1.02 N000200, BH16NS55 1.00, 1.01, 1.02,
                     BH16NS58 1.00, WH14NS40 1.00 N001401, 1.02 N000100, WH16NS40 1.02 N001401)