2,526

Savagesteel wrote:

I get the same error:

This problem can't be fixed now.
Try below.
1. Change the drive speed.
2. Resurface if scratches exist in the disc.
3. Change the disc if possible
4. Change the drive if possible.

2,527

so, I already submitted this information to DICUI for update, but I wanted to share here also.  I was talking with Enker about the layerbreak information for xbox discs, and apparently people (myself included until I discovered the issue) have been submitted the incorrect layerbreak for xbox discs, when they should essentially all be the same default one. 

Here is what Enker shared with me:

"Hey, yes the DICUI layerbreak for Xbox/Xbox360 (and also Blu-ray discs) is incorrect. It's caused by DIC reporting two layerbreaks, one for the video partition and one for the game partition (DICUI uses this one). It never logs the actual layerbreak that takes into account the video partition+middle zone that comes before the game partition. If you add the video LayerZeroSector + Middle Zone + game LayerZeroSector, then you get the default value on the disc page.

DICUI could omit the layerbreak for Xbox/Xbox360/Blu-ray discs, since we never need to enter one for those discs."

As I said, I've already sent this to DICUI to pull the correct one, but I wanted to share with you as well sarami, in case anything has to be done on the DIC side.

The correct layerbreak is apparently the default of 1913776, and not the 1715632 that often/sometimes gets reported.

2,528 (edited by Savagesteel 2020-05-19 16:51:51)

sarami wrote:

1. Change the drive speed.
2. Resurface if scratches exist in the disc.
3. Change the disc if possible
4. Change the drive if possible.

1. I tried with 2x, 4x and 20x and had the same error
2. The disc is in very good condition I cannot see any scratch or damage
3. Yes in the following weeks I will scout ebay to get one and  compare the dumps smile
4. Unfortunately I don't have a second drive which supports 0xC8 instructions

Also when I dump the disc with IsoBuster and the same Plextor drive the image has the same size but data is different (different hash).
When dumping the disc with IsoBuster and two different drives I get the same image file (same hash).

Plextor PX-712A (Firmware 1.09)
Lite-On iHAS124 (Firmware CL9J)

2,529

Savagesteel wrote:

Also when I dump the disc with IsoBuster and the same Plextor drive the image has the same size but data is different (different hash).
When dumping the disc with IsoBuster and two different drives I get the same image file (same hash).

Perhaps, your disc is no problem.
Try to downgrade the firmware and test DIC with no-firmware-check build. http://forum.redump.org/post/74000/#p74000

sadikyo wrote:

The correct layerbreak

http://www.mediafire.com/file/eq80y20l9 … st.7z/file
Added: output layerbreak to _disc.txt (only xbox or xbox 360)

2,530

http://forum.redump.org/post/79651/#p79651 - could you look at it? Why does it have a missing sector (resulting in incorrect lead-in and first pregap sizes)?

Heartbreak Diary also has a weird lead-in size, probably incorrect. And the "Subs indexes" cue is missing its lead-out/lead-in/pregap tags, bug?

2,531

09chairs --- reentrant reported this problem. http://forum.redump.org/post/79155/#p79155 Perhaps, this occurs by the combined offset minus disc. I'll get this disc to test.

Heartbreak Diary --- RevQuixo reported this problem. http://forum.redump.org/post/79442/#p79442 Perhaps fixed it by the latest test version.

And the "Subs indexes" cue is missing its lead-out/lead-in/pregap tags, bug?

Ah yes. I'll fix it.

2,532

sarami wrote:

I'll get this disc to test.

https://www.mercari.com/jp/items/m39989856327/
https://www.mercari.com/jp/items/m84877193423/



There's also a problem with CCD and IMG files for multisession discs. IMG files should not contain the lead-out+lead-in+1st-pregap areas, it should only contain all the tracks merged together (these areas should be skipped while descrambling from scm to img).

And some CCD indexes are wrong. I'm attaching CloneCD, T..p and DIC .ccd files for http://redump.org/disc/70115/ (removed INDEX01 entries from DIC cue for easier comparison). DIC's [Entry 20] is incorrect.

Post's attachments

herders_ccd.7z 930 b, 1 downloads since 2020-05-23 

You don't have the permssions to download the attachments of this post.

2,533

And another example, [Entry 5] is incorrect.

Also, it's probably better not to add the additional indexes and catalog/isrc stuff into ccds, since the ccd is a TOC, not CUE replacement and only needs to contain the TOC (including the CD-TEXT stuff, I guess?) and all the additional indexes/MCN/ISRC stuff can be taken from the sub.

Post's attachments

piersolar_ccd.7z 622 b, 1 downloads since 2020-05-23 

You don't have the permssions to download the attachments of this post.

2,534

http://forum.redump.org/topic/28059/abn … ory-rev-a/ -- have you seen this? weird issue

2,535

F1ReB4LL wrote:

IMG files should not contain the lead-out+lead-in+1st-pregap areas, it should only contain all the tracks merged together (these areas should be skipped while descrambling from scm to img).

F1ReB4LL wrote:

And some CCD indexes are wrong.

ok, I'll fix it.

F1ReB4LL wrote:

Also, it's probably better not to add the additional indexes and catalog/isrc stuff into ccds

But CloneCD outputs them.

F1ReB4LL wrote:

have you seen this? weird issue

Perhaps, it was fixed when I fixed about ROM^2 Karaoke Volume 5 at 2019-12-23.