1,926 (edited by Nexy 2019-07-07 12:32:19)

I am unable to dump this disc because of a Q subchannel checksum being 0. The disc is fine and dumps fine with other tools.

Would you check it please.

possible mastering error from clonecd dump?

attached subs from clonecd.

Post's attachments

Winter Race 3D.7z 1.07 mb, file has never been downloaded. 

WR3D_SCH.7z 444.76 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.
Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,927 (edited by sarami 2019-06-18 01:49:33)

F1ReB4LL wrote:

http://forum.redump.org/topic/22567/ss- … gether-us/ -- this disc has a confirmed sub desync, but the recent DIC doesn't create the 'subs indexes' set of files (actually, the tracks are the same for both TOC and sub indexes, but the gaps in cue differ).

http://www.mediafire.com/file/eq80y20l9 … st.7z/file
- fixed: Desync flag was not set in some cases

Nexy wrote:

I am unable to dump this disc because of a Q subchannel checksum being 0.

This problem occurs when disc is reread. If you use /nq flag, this problem doesn't occur. (But SubQ channel isn't fixed.)

1,928

OK, thanks.

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,929

Before it slips my radar again, I wanted to mention that BD-R dumping still hangs for me. pic.bin dumps, but the .iso doesn't even begin to.

1,930

http://www.mediafire.com/file/eq80y20l9 … st.7z/file
- added: support PS3 drive (needs 3k3y ripper)
- added: sacd command (But SACD iso is scrambled like DVD CSS)

user7 wrote:

Near sector it slowed down/chopping progress: 22600000/23652352

If you have BD-ROM whose size is 43GB over, try to dump and report plz.

1,931 (edited by user7 2019-06-26 06:07:02)

DIC seems to be struggling with *-R's.

Here's logs from the most recent test build, plus IsoBuster Properties and IMGBurn Discovery showing a different size from a CD-R dump: https://drive.google.com/drive/folders/ … sp=sharing

This isn't the first time I've had issues with CD-Rs dumping properly in DIC. A year or so back some other betas were dumping imporoperly in DIC, but properly in IsoBuster.

1,932

user7 wrote:

IsoBuster Properties and IMGBurn Discovery showing a different size from a CD-R

75577 * 2048 = 154781696 (IsoBuster, IMGBurn)
75577 * 2352 = 177757104 (DIC)

Are there sync, msf ecc and edc in IsoBuster and IMGBurn image?

1,933

How do I check?

1,934

Extract the track as raw data(2352) in ISObuster that should match the DIC output with all the ECC etc (rather than just the user data)

1,935

You're right, it matched. Thanks.

1,936 (edited by Nexy 2019-06-28 11:14:53)

Two things, when dumping Links 2001, which has SafeDisc I used;

DiscImageCreator.exe cd h "..\Track" 16 /d8 /c2 20 /s 2 /sf

After reading the whole disc, it went back and tried to re-read the SafeDisc sectors? Very strange behavior that I have no seen it do before and I've dumped quite many SafeDisc now with the same command line.

Also I've noticed that setting read speed to 8, 16, 24, 32, 40 makes no difference with CD dumps and it is always dumping at the same speed (about 4x?), but the disc is audibly spinning faster. DVD Dumps fast. I did not try without C2, but this should not make any differences as it doesn't slow down Plextools, OptiDriveControl or EAC. I asked some others to test that in the Discord.

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,937

Uploaded. https://github.com/saramibreak/DiscImag … r/releases

Nexy wrote:

After reading the whole disc, it went back and tried to re-read the SafeDisc sectors?

I can't comment without logs.

Nexy wrote:

Also I've noticed that setting read speed to 8, 16, 24, 32, 40 makes no difference with CD dumps and it is always dumping at the same speed (about 4x?)

No problem with my PX-755.

1,938 (edited by reentrant 2019-06-29 14:52:45)

Mr Nexy: Problem with Plextor and 8x:

http://forum.redump.org/topic/13211/fir … or-drives/

"P.S.: If you own a Plextor drive which features the silent mode (for example: Premium, Premium 2 and PX-7xx drives [for this serie only the true ones, not the rebadged ones]), NEVER enable the silent mode. This funcion is somewhat buggy, and after of that your drive maybe remains stucked forever at 8x read speed for CD, even if you disable that mode."

All my drives are stucked at 8x. Shit happens?

1,939 (edited by Nexy 2019-06-29 22:42:07)

My drives have never been put in silent mode, they read fast when installing from them, and with any other tool. Perhaps this is why the set speed fails on my Yamaha CRW-F1, there is a bug in it. Tried 716SA, 760A, 5224 and 4824, all same behavior. All drives are able to rip discs with Alcohol or CloneCD at 40X, and Plextools and OptiDriveControl read tests are fine.

Logs for Links 2001 https://drive.google.com/open?id=1AYSSI … zKUDWHDMgd

:EDIT:

Ripping audio discs with C2 and EAC is also fine.

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,940 (edited by sarami 2019-06-30 04:28:25)

Nexy wrote:

Perhaps this is why the set speed fails on my Yamaha CRW-F1, there is a bug in it.

Does CRW-F1 support SET_CD_SPEED (0xbb) ?

Nexy wrote:

Links 2001

Uploaded. http://www.mediafire.com/file/eq80y20l9 … st.7z/file
This disc has two 00000001.TMP. I fixed as only 1st 00000001.TMP is recognized.

reentrant wrote:

NEVER enable the silent mode. This funcion is somewhat buggy, and after of that your drive maybe remains stucked forever at 8x read speed for CD, even if you disable that mode.

I didn't know it. My 755 is already stucked...

1,941

Thanks for fix. Actually I feel like I should thank you so much for making this tool, it has made dumping so much smoother to do and saved me countless errors and loads of time. You should start a patreon or something so we can donate to you.

As for the Yamaha it should if that's a standard command, I am able to change the speed with other tools fine.

The strange thing with dumping speed, I don't know, the disc does speed up but the time taken is the same. Some bottleneck?
I got Haldrie to test this too, same thing.

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,942

http://forum.redump.org/topic/22985/ss-pd-demo/ - any idea why the descrambling failed/cancelled for the 2nd dump?

1,943

sarami wrote:
F1ReB4LL wrote:

http://forum.redump.org/topic/22567/ss- … gether-us/ -- this disc has a confirmed sub desync, but the recent DIC doesn't create the 'subs indexes' set of files (actually, the tracks are the same for both TOC and sub indexes, but the gaps in cue differ).

http://www.mediafire.com/file/eq80y20l9 … st.7z/file
- fixed: Desync flag was not set in some cases

Still doesn't work properly. http://forum.redump.org/post/70904/#p70904

FILE "subpop (1) (Subs indexes) (Track 01).bin" BINARY
  TRACK 01 AUDIO
    INDEX 00 00:00:00
    INDEX 01 00:00:32

Should be "INDEX 01 00:00:33".

FILE "subpop (1) (Subs indexes) (Track 09).bin" BINARY
  TRACK 09 AUDIO
    INDEX 01 00:00:03

Missing "INDEX 00 00:00:00".

The .sub file itself is correct and sub2cue detects "INDEX 01 00:00:33" for track 1 and "INDEX 00 00:00:00" for track 9 properly, so it's the DIC's gap detection bugged.

1,944

F1ReB4LL wrote:

Still doesn't work properly.

Uploaded test version. http://www.mediafire.com/file/eq80y20l9 … st.7z/file

1,945

sarami, may I ask for a switch that will prevent filling SafeDisc and other error sectors with 0x55 when descrambling?

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,946

I am having a problem dumping Hegmonia - Legions of Iron, here are the logs. https://drive.google.com/open?id=1g54NB … seEeQ3qHzB

Looking at the data that was dumped, the first bad MSF sector has an ecc/edc error and the additional blocks the sync is shifted over in the blocks by 16 bytes, where the first 16 bytes are some random bytes or from the previous sector.

The disc dumps without issue in CloneCD and Alcohol.

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,947

Can you also make an option to reduce the read speed when encountering errors.

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,948

FatArnold has enountered the MSF bug on the linux build with safedisc in this thread, there is logs posted. http://forum.redump.org/post/71345/#p71345

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)

1,949

Nexy wrote:

sarami, may I ask for a switch that will prevent filling SafeDisc and other error sectors with 0x55 when descrambling?

Why?

Nexy wrote:

I am having a problem dumping Hegmonia - Legions of Iron

Nexy wrote:

FatArnold has enountered the MSF bug on the linux build with safedisc

Please check by cdtoimg.exe (d8 hacked)

1,950

sarami wrote:
Nexy wrote:

sarami, may I ask for a switch that will prevent filling SafeDisc and other error sectors with 0x55 when descrambling?

Why?

Because I want to examine the sector data, the C2 error is always in bit 312, I think this is like CDS and there is nothing "wrong" with the dumped data.

I am working on a SafeDisc unwrapper to remove it and I want to examine everything about it I can.

What would I check with cdtoimg when it cannot dump safedisc? I can post the sectors if you want to look at the output of my disc.

Plextor PX-760A 1.07 (+30) : Plextor PX-716SA 1.11 (+30) : Plextor PX-W5224A 1.04 (+30) : Plextor PX-W4824 1.07 (+30) : Plextor PX-W4012TA 1.07 (+98) : Plextor PX-W1610TA (+99) : Plextor PX-W1210TA 1.10 (+99) : Lite-On LTR-48246S (+6) : Lite-On LTR-52246S (+6) : Lite-On LH-20A1H LL0DN (+6) : BenQ DW1655 BCIB (+618) : ASUS DRW-2014L1 1.02 (+6) : Yamaha CRW-F1 (+733) : Optiarc SA-7290H5 1H44 (+48) : ASUS BW-16D1HT 3.02 (+6)