2,501

sarami wrote:
RevQuixo wrote:

Same error with test version.

Re-uploaded.  http://www.mediafire.com/file/eq80y20l9 … st.7z/file


And fixed!  Thanks for the quick turn around.

2,502

PS4 kiosk disc seems to not want to dump properly, possibly related to the recent blu-ray updates? https://drive.google.com/file/d/1tPbF98 … sp=sharing

2,503

No.

2,504

Everybody is having problems with the new firmware check, plz remove it!

2,505

So I'm out of my element here so please forgive my ignorance.  There has been some heated discussion in discord about whether we are creating proper cues for unlicensed DC games specifically revolving the lead-outs and pre-gaps.  Cartain folks think we aren't generating the cue properly to match standards.  As an example here is the cue for Elansar (a recently dumped unlicensed DC game)

REM SESSION 01
FILE "Track 01.bin" BINARY
  TRACK 01 AUDIO
    INDEX 01 00:00:00
REM LEAD-OUT 01:30:00
REM SESSION 02
REM LEAD-IN 01:00:00
REM PREGAP 00:02:00
FILE "Track 02.bin" BINARY
  TRACK 02 MODE2/2352
    INDEX 01 00:00:00

and here is the suggested "proper" cue

REM SESSION 01
FILE "Track 01.bin" BINARY
  TRACK 01 AUDIO
    INDEX 01 00:00:00
REM LEAD-OUT 00:04:02
REM SESSION 02
FILE "Track 02.bin" BINARY
  TRACK 02 MODE2/2352
    INDEX 01 00:00:00

log is here:
https://drive.google.com/open?id=1lsiBG … mwL1M5D8e2

The conversation is way over my head, but thought I'd bring it to the attention of folks in the know for discussion.  We'd like to start getting these discs into the DB "properly", so might as well get it right before we have too many dumped a potentially incorrect/inadequate way.  As I said though, I don't have any notion as to if they are good as is or not.

2,506

@RevQuixo
See -> http://forum.redump.org/topic/20409/don … ssion-cue/

@Jackal
It's completely DICUI problem and it was fixed by DICUI WIP build https://ci.appveyor.com/project/mnadare … /artifacts

2,507

I'm having trouble dumping the original xbox game Furious Karting. DIC hangs at Reading DirectoryRecord for about 15 mins.I then get a "[F:ReadXBOXDirectoryRecord][L:1129] GetLastError: 87, The parameter is incorrect" and it closes. It does give me the DMI PFI & SS which all match the database. The volDesc and mainInfo files created come in at 6.2Mb and 20.00Mb which seem quite large. No iso file is created and the reading sectors never even starts. I've dumped the same game with xbox backup creator and it matches in the existing database here

2,508

R00n5t3r wrote:

I'm having trouble dumping the original xbox game Furious Karting.

Logs are needed.

2,509

sarami wrote:
R00n5t3r wrote:

I'm having trouble dumping the original xbox game Furious Karting.

Logs are needed.

Post's attachments

furious karting.7z 878.47 kb, 1 downloads since 2020-05-11 

You don't have the permssions to download the attachments of this post.

2,510

The version is too old.

20190629 193630

Try this http://www.mediafire.com/file/eq80y20l9 … st.7z/file

2,511

sarami wrote:

The version is too old.

20190629 193630

Try this http://www.mediafire.com/file/eq80y20l9 … st.7z/file

Tried this and get the same thing.

Interestingly when I try and load the iso created with xbox backupcreator into an iso tool to get the layout it comes back with invalid TOC entry

Post's attachments

Capture.PNG 18.92 kb, file has never been downloaded. 

fur k.7z 881.4 kb, 3 downloads since 2020-05-12 

You don't have the permssions to download the attachments of this post.

2,512

Added some logs into _maininfo.txt. http://www.mediafire.com/file/eq80y20l9 … st.7z/file
Upload logs again, plz.

2,513

sarami wrote:

Added some logs into _maininfo.txt. http://www.mediafire.com/file/eq80y20l9 … st.7z/file
Upload logs again, plz.

Post's attachments

fur k.7z 888.65 kb, 1 downloads since 2020-05-12 

You don't have the permssions to download the attachments of this post.

2,514

Transfer length was too large.

uiDirPos: 341431, TransferLength: 82

Fixed it. Test plz. http://www.mediafire.com/file/eq80y20l9 … st.7z/file

2,515

sarami wrote:

Transfer length was too large.

uiDirPos: 341431, TransferLength: 82

Fixed it. Test plz. http://www.mediafire.com/file/eq80y20l9 … st.7z/file

I'm away for the next few days but should be able to test on Monday 18th.

Since last weekend, I've been working a lot to understand OpCode 0xF1 and test firmwares with it and I've managed to find that my HL-DT-ST GH24NSD1 LG00 supports it. However the laser is pretty bad by design and it has problem with one feature (FlushDriveCache) that works with ASUS BW-16D1HT 3.02 (Official / DE). So GH24NSD1 probably shouldn't be supported until I've figured out if it could be good and stable to use with DiscImageCreator.

On the other hand, I've tested HL-DT-ST WH16NS60 1.00 (Official / DE) and it works great! big_smile

Thank you sarami for providing me with a test version for Linux to let me test it and I will (together with other users) test a lot of firmwares for PCB Revision JB7 2011.11.17, JB8 2015.05.08, JBC5 2012.05.02, JB9 2015.09.03 smile
... and more wink

Main ODDs: QEMU (MSWinXPSP3): PLEXTOR DVDR PX-708A 1.03 (+30) | PLEXTOR - CD-R PREMIUM 1.07 (+30) | ASUS BW-16D1HT 3.02 (DE) (+6).
I've got access to approx. 150 different ODDs and a scanner supporting 3 200 x 6 400 DPI.
Blue = Additional information. Red = Change/update information

2,517 (edited by sarami 2020-05-15 04:23:37)

olofolleola4 wrote:

Thank you sarami for providing me with a test version for Linux

Also uploaded Windows test build.
And other changes are here.
- added: support for make install command [Linux only] (Thx pseiler)
- added: detect SecuROM 4.xx
               -> output SecuROM DLL header to _volDesc.txt
               -> if app finds "InterShield Cabinet File" or "MicroSoft Cabinet File", decompress it [Windows only]
- added: output ISRC country, owner, year, serial to _disc.txt
- changed: Data and Time format (ISO8601)
- fixed: search PSX anti-mod string

2,518

sarami wrote:

Transfer length was too large.

uiDirPos: 341431, TransferLength: 82

Fixed it. Test plz. http://www.mediafire.com/file/eq80y20l9 … st.7z/file

I was having the same problem - but I tried with the new test version you shared here - and it worked.  Thanks!

2,519

sadikyo wrote:

I was having the same problem - but I tried with the new test version you shared here - and it worked.  Thanks!

Thanks test. I want to see your disc log. Would you upload them?

2,520 (edited by sadikyo 2020-05-16 15:13:43)

sarami wrote:
sadikyo wrote:

I was having the same problem - but I tried with the new test version you shared here - and it worked.  Thanks!

Thanks test. I want to see your disc log. Would you upload them?

Yes - this is the one that worked with the test version

Post's attachments

Blinx - The Time Sweeper (Demo) (Japan) (MS-019).7z 86.74 kb, 3 downloads since 2020-05-16 

You don't have the permssions to download the attachments of this post.

Hello there,

I'm dumping the Diablo 1 shareware PC CD-ROM.
I'm using:

  • DiscImageCreator 20200403

  • Plextor PX-712A drive

  • Windows 10 x64

I dump the disc with the following command:

C:\Program Files\DiscImageCreator\Release_ANSI\DiscImageCreator.exe cd E .\temp\Diablo-Shareware.bin 8 /c2

I get no C2 errors however in the mainError.txt I get the following error:

LBA[031892, 0x07c94]: Track[01]: Invalid sync. Skip descrambling

I don't know how to interpret it, can you please advise?

Plextor PX-712A (Firmware 1.09)
Lite-On iHAS124 (Firmware CL9J)

2,522

sarami wrote:

Transfer length was too large.

uiDirPos: 341431, TransferLength: 82

Fixed it. Test plz. http://www.mediafire.com/file/eq80y20l9 … st.7z/file

That seems to have done the trick. New logs are enclosed

Post's attachments

furk.7z 1.18 mb, 1 downloads since 2020-05-18 

You don't have the permssions to download the attachments of this post.

2,523

@R00n5t3r, sadikyo
Thanks. The src was pushed.

Savagesteel wrote:

I don't know how to interpret it, can you please advise?

All logs are needed and use the latest test version.

2,524 (edited by Savagesteel 2020-05-19 06:01:47)

@sarami
Thank you for your answer, please find below the link for the logs:
http://www.mediafire.com/file/5446vlhsb … e_logs.zip

I will redump with the test version and also post the logs.

Plextor PX-712A (Firmware 1.09)
Lite-On iHAS124 (Firmware CL9J)

Below the logs with 20200517, I get the same error:
http://www.mediafire.com/file/fnwjb0xr8 … 200517.zip

Plextor PX-712A (Firmware 1.09)
Lite-On iHAS124 (Firmware CL9J)